Troubleshooting

Cannot Install Utility on Older PC Running Windows XP

Attempting to install the latest version of the Concept2 Utility on an older PC running Windows XP may result in errors or difficulties.

If you plan to use a PM3 or PM4 with the Concept2 Utility, then downloading and installing Version 6.54 of the Concept2 Utility may solve the problem; however, if you plan to upload results to your online logbook, please be aware that older versions of the Concept2 Utility will not be compatible with the online logbook in the future.

PM5 use with older versions of the Concept2 Utility is not possible, because the versions of the Concept2 Utility that run on Windows XP do not support the PM5 monitor.