Troubleshooting

Cannot Install Utility on Mac OS X 10.8 or 10.9

When trying to install the Concept2 Utility, Mac users running Mac OS X 10.8 or higher may encounter a warning message that reads "Concept2 Utility 6.50 can’t be opened, because it is from an unidentified developer." This issue has been resolved in Version 6.54 and higher. Please download and install the latest version instead.