System Requirements

The Concept2 Utility is Windows and Mac compatible. Refer to the system requirements below.

For optimal usage, Concept2 recommends that all PM users upgrade to the latest firmware version available for the model PM you have. Learn more: PM5 | PM4 | PM3

Windows

  • Windows 10, 8, 7, or Vista
    Notes:

    • If you are attempting to install the Concept2 Utility from an older CD that is not supported by Windows 7 or Vista, please download the Concept2 Utility from our website instead.
    • Users of Omnikey readers may need to acquire and install appropriate drivers from OmniKey.
    • Windows XP Pro, XP Home, 98, Me and 2000 are not officially supported but may work.
    • Windows RT (as run on the Microsoft Surface and Surface 2) is NOT supported.
    • The Surface Pro, Surface Pro 2, Suface 3 and Surface 4 which run Windows 8 or Windows 10, should work with the Utility, however, however the screen DPI setting will need to be adjusted for optimal experience.
  • Working USB port to connect USB flash drive, PM or external card reader (when using the PM with the Concept2 Utility, a USB cable is also needed)
  • Optional: Internet connection to perform internet-related tasks such as:
    • Uploading workouts to the Concept2 Online Logbook
    • Receiving notifications that a new Concept2 Utility Version is available
    • Downloading new versions of PM firmware
  • Recommended: Internet connection to obtain the latest firmware version.
    Notes:

    • If you plan to use a PM3 with the Concept2 Utility to read your LogCard, many Concept2 Utility functions are not available unless the PM3 is running Firmware Version 90 or above.
    • Mac users who would like to use their PM3 in conjunction with the Concept2 Utility must upgrade to Firmware Version 90 or above.
    • For optimal usage, Concept2 recommends that all PM users upgrade to the latest firmware version available for the model PM you have. Learn more about: PM5 firmware | PM4 firmware | PM3 firmware
  • Optional for PM3/PM4 Users:
    • Athena ASE IIIe card reader
    • OmniKey CardMan 3121 card reader

Macintosh

  • OS X 10.6–10.11
  • Working USB Port to connect USB flash drive, PM or external card reader (when using the PM with the Concept2 Utility, a USB cable is also needed)
  • Optional: Internet connection to perform internet-related tasks such as:
    • Uploading workouts to the Concept2 Online Logbook
    • Receiving notifications that a new Concept2 Utility Version is available
    • Downloading new versions of PM firmware
  • Firmware Version 90 or above for PM3 users (Version 97 or later recommended)
    Note: PM3s must be upgraded to Version 90 or above on a Windows PC prior to use with a Macintosh.
  • Optional for PM3/PM4 Users:
    • Athena ASE IIIe card reader
    • OmniKey CardMan 3121 card reader

Summary of Supported Features and Versions

Operating System Versions Windows Macintosh
Tested and supported: Windows 8
Windows 7
Windows Vista
10.11
10.10
10.9
10.8
10.7
10.6

Untested, may work: XP Home
XP Pro
98SE
Me
2000
XP 64 bit
10.5
Not supported/compatible RT
95
98
10.4.2
10.3
10.2
9
Device Compatibility
PM3 Firmware Version 89 or below Limited functions No
PM3 Firmware Version 90 and above Yes *
* PM3 Firmware Version 101 required for use with Concept2 Utility 6.10
Yes
PM4 Firmware Version 14 and above Yes Yes
PM5 Firmware Version 12 and above Yes Yes
USB flash drive Yes Yes
Card readers For compatibility information, visit Card Reader Overview and Requirements.
Device Compatibility
Update PM3 firmware Yes Must update to Firmware Version 97 using a PC first, then can use a Mac to install future firmware updates
Update PM4 firmware Yes Yes
Update PM5 firmware Yes. Must have Concept2 Utility version 6.77 or higher. Yes. Must have Concept2 Utility version 6.77 or higher.